Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Tutoriel et Help

Style & CSS


Accueil

Accueil CHM


Composants de base - Diodes Zener

Vu dans ... http://res-nlp.univ-lemans.fr/NLP_C_M15_G01/co/Contenu_g5.html

Composants de base - Diodes Zener - Caractéristiques

Si l'épaisseur de la jonction est faible et si le taux de dopage est important, on obtient des diodes qui présentent un courant inverse intense au-delà d'une valeur [image] de la tension inverse qui est la tension de coude ou de Zener.

Le claquage inverse de la jonction résulte soit d'un claquage par avalanche par ionisations dans la zone de déplétion par les porteurs, soit d'un claquage par effet Zener qui correspond au passage des électrons de la bande de valence à la bande de conduction sous l'effet du champ électrique.

Figure 21

Remarque

Si la construction de la diode permet la dissipation de la puissance dégagée, le claquage est réversible. On obtient alors une diode Zener. Sa caractéristique directe est identique à celle d'une diode classique.

Pour les diodes Zener avec [image] , la résistance dynamique est voisine de quelques ohms et le coude très brutal. (claquage par avalanche). Pour [image] le coude est arrondi car il y a claquage par effet Zener. Si [image] est très supérieur à [image] la résistance dynamique augmente. Selon le courant débité, la tension aux bornes de la diode sera d'autant plus stable que la résistance dynamique de celle-ci sera faible.

Attention

Les diodes tunnels sont des diodes Zener dont le dopage est si grand que la tension inverse est nulle. Leur caractéristique présentant une zone de pente négative ces diodes sont utilisées dans des circuits oscillateurs.

Stabilisation de tension

Remarque

Il est possible de réaliser un stabilisateur de tension en utilisant une diode Zener.

On suppose que le courant inverse [image] dans la diode est tel que le point de fonctionnement est situé dans la partie linéaire de la caractéristique. Il est alors possible de modéliser la diode par l'association d'une source de tension [image] en série avec une résistance [image] (résistance dynamique inverse de la diode).

Figure 22
Figure 23

Remplaçons le générateur (tension [image] et résistance [image] ) et la résistance de charge par leur équivalent Thévenin :

Le point de fonctionnement de la diode est obtenu en cherchant l'intersection de sa caractéristique [image] avec la droite de charge d'équation [image] .

On retrouve graphiquement le fait que le système ne fonctionne que si [image] .

Figure 24

  • . Si la charge varie, (stabilisation amont) les courants dans la charge et dans la diode varient mais [image] reste constant car la pente de la droite de charge varie. De même si la tension du générateur varie (stabilisation aval) [image] reste également constant car la droite de charge se déplace parallèlement à elle-même.

  • . varie avec les paramètres extérieurs. Pour la stabilisation aval (variation [image] de [image] ), on peut déterminer [image] en recherchant les intersections de la caractéristique avec les droites de charge qui correspondent aux valeurs extrêmes de [image] . Il est plus efficace d'étudier le schéma équivalent au montage en régime de petits signaux. Le générateur est remplacé par un générateur de f.e.m. , la diode par sa résistance [image] puisque [image] est constant.

avec [image] et

Comme [image] est petit, [image] . On en déduit :

La stabilisation est d'autant meilleure que [image] est petite.

Figure 25

Remarque :

La puissance ( [image] ) dissipée dans la diode doit toujours rester inférieure à la puissance maximale autorisée. varie avec la température et pour certaines applications, il est nécessaire d'en tenir compte.

Il est possible d'obtenir une stabilisation beaucoup plus efficace en utilisant des montages à transistors ou des régulateurs tripodes intégrés.


diodes leds

Vu dans ... http://etronics.free.fr/dossiers/analog/analog12/diodeled.htm

Les diodes LED

1.1.Descriptions

Les D.E.L (Diode ElectroLuminescente) ou en Anglais : L.E.D ( Light Emitting Diode) éclairent lorsqu' elles sont parcourues par un courant de l'anode vers la cathode.

1.2.Symboles

1.3.Unités ; Formules

La tension de seuil dépend de la couleur et donc de la composition chimique du dopage .

Couleurs | Tension de seuil OU Vf | If (mA) | Longueur d' onde
Rouge | 1,6 V à 2 V | 6à20 | 650 à 660 nm
Jaune | 1,8 V à 2 V | 6à20 | 565 à 570 nm
Vert | 1,8 V à 2 V | 6à20 | 585 à 590 nm
Bleu | 2,7 V à 3,2 V | 6à20 | 470 nm
blanc 3,5 v à 3,8 v 30

Par exemple calcul de la résistance pour une led rouge

R1 = (V-Vf) / If, donc R 1= (12 - 1,8 ) / 0,02 = 510 ohms , bien souvent ont utilise une résistance de 470 ohms Iled = ( 12 - 1,8 ) / 470 = 0,021A ou 21 mA

Dans la documentation vous aurez aussi
la tension inverse max Vr ( reverse voltage )
le courant max en pointe pour un temps très court IFSM ( surge current )

1.4.Valeurs

1.4.1.LED standard

Les LEDS rondes de diamètre 3 mm ou 5 mm comportent un plat sur la base pour repérer la cathode ( ou lorsqu' elles sont neuves la patte la plus courte ).La consommation moyenne est d' environ 20 mA.

1.4.1.1.Extrait de fiche technique d'une LED :

1.4.2.Les LEDS miniatures

Led de diamétre1,9 au pas de 2,54 mm pour implantation directe sur un circuit ayant une consommation de 20 mA .

1.4.3.Les LEDS faible consommation

Elles consomment de 2 mA à 6 mA .

1.4.4.Les LEDS avec résistance interne

Avec ces leds vous n' avez pas besoin d' utiliser de résistance extérieur , elles peuvent fonctionner directement sur un tension de 5V ou 12V.

1.4.5.Les LEDS clignotantes

Ces leds ont un circuit électronique permettant le clignotement avec une fréquence de 1 à 2,5 Hz/seconde .La plage d'alimentation est de 3,5V à 5V et pour une utilisation avec des tensions supérieurs il faut ajouter une résistance .Il y a maintenant aussi des leds avec résistance intégré pour une utilisation en 12 v .

1.4.6.Les LEDS bicolores , tricolores ou multicolores

Il existe des leds bicolores à 2 ou 3 pattes , avec 2 pattes la couleur est différente suivant le sens du courant ( rouge ou vert ) ,et avec 3 pattes la cathode est la patte commune au centre ; la première patte est l'anode rouge et la 3éme l'anode verte ; si les deux anodes sont alimentées cela donne une troisième couleur orange .

1.4.6.Les LEDS de formes spéciales

Les leds peuvent prendre toutes les formes , rectangulaire , triangulaire , carré , ronde ( différents diamètres jusqu' 20 mm ) .

Des leds groupées par 7 , 10 alignées verticalement forment ce que l 'on appelle un Bargraph .

Un afficheur à led regroupe 7 leds rectangulaires et une led ronde pour le point .

Un afficheur à matrice de points 5 x 7 comporte 35 leds rondes , 5 horizontalement sur 7 verticalement .

1.5.Variantes

Les leds infrarouges ou diodes d'émissions s' utilisent beaucoup pour les télécommandes IR de télévisions et chaînes hi-fi.

1.6. Utilisations

L' avantage d' utiliser des leds est qu' elles ne s' usent pas , elles sont moins chère que des voyants , elles consomment moins d' énergie .Mais l' inconvénient et qu'elles ne peuvent fonctionner qu'avec une faible tension , et qu' elles n' éclairent pas beaucoup par rapport aux ampoules classiques .

Il faut donc ajouter une résistance en série pour utiliser un Led .

En fonction de la résistance l' intensité va varié et la luminosité aussi .

Il est aussi possible de faire varier l' intensité lumineuse en appliquant une fréquence variable

2.1.Composition

2.2.Formules +

Pour mettre plusieurs leds en séries il faut additionner la tension de seuil de chaque led puis ce laisser une marge de quelques volts afin de mettre un résistance en série dans la circuit .

3.1.Exercices

Pour faire clignoter une led il faut un circuit oscillateur , il est possible d' utiliser des portes logiques ou des ampli op mais la plus utilisé est le NE555 .
voir page : http://etronics.free.fr/dossiers/analog/analog60

Une autre solution consiste à utiliser une led clignotante, mais la fréquence sera fixe ( environ 3 impulsions par secondes ) ; c' est à dire que la vitesse du clignotement ne pourras pas être modifié comme avec un circuit oscillateur .

voir si vous voulez faire clignoter plusieurs leds ordinaires il suffit de mettre en série la led clignotante et de calculer la résistance en fonction de votre alimentation .

4.1.Programmes

5.1.Liens

Tout sur les leds: historique, application, fonctionnement, expériences ... Led-fr.net

liste de fabriquant de leds : plus de détails cliquez sur le tableau

LED Manufacturer | Website
A-Bright Industrial Co Ltd | www.a-bright.com.tw

Suite vers Diode Émission Réception


Diode électroluminescente — Wikipédia

Vu dans ... https://fr.wikipedia.org/wiki/Diode_%C3%A9lectroluminescente

Diode électroluminescente - Techniques de fabrication

La longueur d’onde du rayonnement émis dépend de la largeur de la « bande interdite » et donc du matériau utilisé. Toutes les valeurs du spectre lumineux peuvent être atteintes avec les matériaux actuels. L’infrarouge est obtenu grâce à l’arséniure de gallium (GaAs) dopé au silicium (Si) ou au zinc (Zn). Les fabricants proposent de nombreux types de diodes aux spécificités différentes. Les diodes à l’arséniure de gallium sont les plus économiques et les plus utilisées. Les diodes à l’arséniure de gallium-aluminium (AlGaAs) offrent une plus grande puissance de sortie mais nécessitent une tension directe plus élevée et ont une longueur d’onde plus courte (< 950 nm, ce qui correspond au maximum de sensibilité des détecteurs au silicium) ; elles présentent une bonne linéarité jusqu’à 1,5 A. Enfin, les diodes à double hétérojonction (DH) AlGaAs offrent les avantages des deux techniques précédentes (faible tension directe) en ayant des temps de commutation très courts (durée nécessaire pour qu’un courant croisse de 10 % à 90 % de sa valeur finale ou pour décroître de 90 % à 10 %), permettant des débits de données très élevés dans les transmissions de données numériques par fibres optiques. Les temps de commutation dépendent de la capacité de la jonction dans la diode.

Efficacité lumineuse[ | ]

Un ours éclairé par des diodes électroluminescentes.

L'efficacité lumineuse varie selon le type de diodes, de 20 à 100 lm/W, et atteignant en laboratoire les 200 lm/W[13]. Une grande disparité de performances existe selon la couleur (température de couleur pour le blanc), la puissance ou encore la marque.
Les bleues n’excèdent pas 30 lm/W alors que les vertes ont une efficacité lumineuse atteignant 100 lm/W[14].

La limite théorique d’une source qui transformerait intégralement toute l’énergie électrique en lumière visible est de 683 lm/W[15], mais il faudrait qu’elle possède un spectre monochromatique de longueur d’onde 555 nm. L'efficacité lumineuse théorique d’une LED blanche est de l’ordre de 250 lm/W[16]. Ce chiffre est inférieur à 683 lm/W du fait que le maximum de sensibilité de l’œil se situe vers 555 nm.

L'efficacité lumineuse des LED blanches de dernière génération est supérieure à celle des lampes à incandescence mais aussi à celle des lampes fluocompactes ou encore de certains modèles de lampes à décharge. Le spectre de la lumière émise est presque intégralement contenu dans le domaine du visible (les longueurs d’onde sont comprises entre 400 nm et 700 nm). Contrairement aux lampes à incandescence et aux lampes à décharge, les diodes électroluminescentes n’émettent quasiment pas d’infrarouge, sauf celles fabriquées spécifiquement dans ce but.

L'efficacité lumineuse dépend de la conception de la LED. Pour sortir du dispositif (semi-conducteur puis enveloppe externe en époxy), les photons doivent traverser (sans être absorbés) le semi-conducteur, de la jonction jusqu’à la surface, puis traverser la surface du semi-conducteur sans subir de réflexion et, notamment, ne pas subir la réflexion totale interne qui représente la grosse majorité des cas. Une fois arrivé dans l’enveloppe externe en résine époxy (quelquefois teintée pour des raisons pratiques et non pour des raisons optiques), la lumière traverse les interfaces vers l’air à incidence proche de la normale ainsi que le permet la forme de dôme avec un diamètre bien plus grand que la puce (3 à 5 mm au lieu de 300 µm). Dans les diodes électroluminescentes de dernière génération, notamment pour l’éclairage, ce dôme plastique fait l’objet d’une attention particulière car les puces sont plutôt millimétriques dans ce cas et le diagramme d’émission doit être de bonne qualité. À l’inverse, pour des gadgets, on trouve des LED quasiment sans dômes.

Effet Auger[ | ]

Aux fortes intensités, l'efficacité lumineuse des LED chute. Il a été suspecté en 2007-2008[17],[18], mieux compris en 2010-2011[19],[20] puis confirmé début 2013 que cette diminution est attribuable à un « effet Auger » qui dissipe une partie de l'énergie sous forme de chaleur[21],[22]. Des projets de recherche visent à limiter ou contrôler cet effet[23].

Bilan environnemental[ | ]

Spectres de lampes 1) sodium haute pression et 2) LED testées pour leur caractère plus ou moins attractif sur les insectes[24] (l'étude a montré que le spectre lumineux de la LED était beaucoup plus attractif pour les insectes[24])

Ce bilan est discuté, car le développement massif des LED pourrait augmenter les tensions sur le marché sur certaines ressources non renouvelables (terres rares ou métaux précieux) et parce que la conversion des éclairages urbains aux LED semble souvent susciter une augmentation de l'illumination globale du ciel nocturne et donc de la pollution lumineuse visible de l'espace[25].

D'un autre côté les LED ont un fort potentiel d'économie en énergie, si leur utilisation est raisonnée pour éviter le risque d'effet rebond.

Des préoccupations sérieuses existent concernant les impacts sanitaires de lampes mal utilisées, et surtout via leurs effets de pollution lumineuse.
Ainsi, selon une étude[24] publiée en 2014 dans la revue Ecological Applications, alors que l’éclairage nocturne municipal et industriel a déjà changé la répartition des différentes espèces d'invertébrés autour des sources lumineuses[26] et semble contribuer à la régression ou la disparition de nombreuses espèces de papillons[27], l'éclairage public tend à utiliser à grande échelle les diodes électroluminescentes (LED) ; la question de l’impact des spectres lumineux des lampes prend donc de l’importance[28]. Ces spectres lumineux ont récemment beaucoup changé, et ils changeront encore avec le développement des LED[29]. Or, il apparaît que le spectre lumineux émis par les LED mises sur le marché dans les années 2000-2014 attire les papillons de nuit et certains autres insectes plus que la lumière jaune des ampoules à vapeur de sodium, en raison d’une sensibilité élevée de ces invertébrés nocturnes aux parts vert-bleue et UV du spectre. Des pièges lumineux à insectes volants équipés de LED capturent 48 % plus d'insectes que les mêmes pièges utilisant des lampes à vapeur de sodium, avec un effet également lié à la température de l’air (les invertébrés sont des animaux à sang froid, naturellement plus actif quand la température s’élève). Lors de cette étude plus de 20 000 insectes ont été capturés et identifiés : les espèces les plus fréquemment piégées étaient des papillons et des mouches[24].

Ces lampes sont froides et ne brûleront pas les insectes comme pouvaient le faire des lampes halogènes, mais le caractère très attractif des LED pour de nombreux invertébrés peut leur être fatal ; leur vol est perturbé et dans la zone d'attraction ils sont mis en situation de « piège écologique », car largement surexposés à des prédateurs de type araignées et chauve-souris, avec de possibles effets écologiques plus globaux si ces lampes étaient utilisées à grande échelle (perturbation des réseaux trophiques et possible renforcement des infestations de certaines cultures ou sylvicultures par des « ravageurs phytosanitaires » attirés par ces lampes, tels que le Bombyx disparate qui est source de dégâts importants depuis qu’il a été introduit aux États-Unis et qui se montre très attiré par la lumière[30] (les auteurs pointent les ports où un éclairage LED pourrait directement attirer des ravageurs ou des espèces exotiques envahissantes accidentellement apportées par des bateaux[24]). Ces espèces anormalement favorisées pouvant à leur tour mettre en péril des espèces natives rares ou menacées[31].

L’étude de 2014 n’a pas pu conclure que manipuler la température de la couleur des LED diminuaient leur impact ; mais les auteurs estiment qu'utiliser des filtres ou une combinaison de LED rouges, vertes, et bleues pourraient peut-être diminuer cette fatale attraction, mais alors avec des coûts en termes de consommation électrique et d’énergie [24] ou de terres rares. Ils concluent qu’il existe un besoin urgent de recherche collaborative entre écologues et ingénieurs de la lumière pour minimiser les conséquences potentiellement négatives des développements futurs de la technologie LED[24]. L'écoconception en amont des LED pourrait faciliter le recyclage des lampes usagées et en aval le ré-usage de LED d'objets désuets ou en fin de vie. De même des systèmes intelligents d'asservissement de l'éclairage aux besoins réels sont possibles (lampes équipées de filtres limitant les émissions dans le bleu-vert et le proche-UV, mieux bafflées c'est-à-dire produisant moins de halo et moins éblouissantes, ne s'allumant qu'à l'intensité nécessaire et uniquement quand on en a besoin, via un processus d'éclairage intelligent incluant la détection de présence et de luminosité ambiante, si possible intégré dans un smartgrid ou un système écodomotique plus global. En 2014, quatre villes dont Bordeaux, Riga en Lettonie, Piaseczno en Pologne et Aveiro au Portugal testent ce type de solution dans le cadre du programme européen « LITES »[32] (à l'installation ces systèmes sont 60 % plus cher, mais ce surcoût doit être rapidement récupéré par les économies d'électricité et l'amélioration de la qualité de l'environnement nocturne.

Article détaillé : Pollution lumineuse.

Caractéristiques techniques[ | ]

Forme[ | ]

LED 1 W

Ce composant peut être encapsulé dans divers boitiers destinés à canaliser le flux de lumière émis de façon précise : cylindrique à bout arrondi en 3, 5, 8 et 10 mm de diamètre, cylindrique à bout plat, ou de forme plate (LED SMD[33]), rectangulaire, sur support coudé, en technologie traversante ou à monter en surface (CMS).

Les LED de puissance ont des formes plus homogènes : la luxeon 1 W ci-contre est assez représentative. Ces types de LED sont également disponibles en version « multicœur », « multipuces » ou « multichips » en anglais, dont la partie émissive est composée de plusieurs puces semi-conductrices.

L'enveloppe transparente, ou capot, est généralement en résine époxy, parfois colorée ou recouverte de colorant.

Luminosité[ | ]

L’intensité lumineuse générale des diodes électroluminescentes est assez faible, mais suffisante pour la signalisation sur tableau, ou bien les feux de circulation (feux tricolores, passages piétons). Les bleues sont également suffisamment puissantes pour signaliser les bords de route, la nuit, aux abords des villes. Le bâtiment du NASDAQ, à New York possède une façade lumineuse animée entièrement réalisée en LED (quelques millions).

Les LED de puissance sont aussi utilisées dans la signalisation maritime comme sur les bouées permanentes. Deux de ces diodes sont situées l’une par-dessus l’autre et suffisent à un éclairement important et visible par les bateaux de nuit.

Lampes à diode électroluminescente

Des LED de forte puissance ont vu le jour au début des années 2000. Dans la première décennie du XXIe siècle, des rendements lumineux d'environ 130 lumens/watt sont atteints avec ces LED[réf. nécessaire]. Par comparaison, les ampoules à filament de tungstène de 60 W atteignent un rendement lumineux d'environ 15 lumens/watt[réf. nécessaire].

Les LED sont, en 2014, suffisamment puissantes pour servir d'éclairage dans le secteur de l'automobile. Employées d'abord pour les feux de stop, clignotants ou de recul, celles-ci remplaceront probablement, à terme, toutes les lampes classiques.

Couleurs[ | ]

La couleur de la lumière d'une diode électroluminescente peut être produite de différentes manières[34],[35] :

  • couleur due à la nature du semi-conducteur (capot transparent) : la longueur d'onde émise correspond directement au gap du matériau utilisé ;
  • coloration modifiée par le capot de la diode (émission bleue ou UV + revêtement à base de luminophores) ;
  • coloration par plusieurs émissions de longueur d'onde différentes (diodes électroluminescentes polychromatiques). Elles permettent notamment de proposer une vaste gamme de couleurs[36].

Voici quelques colorations en fonction du semi-conducteur utilisé :

Couleur | Longueur d’onde (nm) | Tension de seuil (V) | Semi-conducteur utilisé
Infrarouge | λ > 760 | ΔV < 1,63 | arséniure de gallium-aluminium (AlGaAs)
Rouge | 610 < λ < 760 | 1,63 < ΔV < 2,03 | arséniure de gallium-aluminium (AlGaAs) phospho-arséniure de gallium (GaAsP)
Orange | 590 < λ < 610 | 2,03 < ΔV < 2,10 | phospho-arséniure de gallium (GaAsP)
Jaune | 570 < λ < 590 | 2,10 < ΔV < 2,18 | phospho-arséniure de gallium (GaAsP)
Vert | 500 < λ < 570 | 2,18 < ΔV < 2,48 | nitrure de gallium (GaN) phosphure de gallium (GaP)
Bleu | 450 < λ < 500 | 2,48 < ΔV < 2,76 | séléniure de zinc (ZnSe) nitrure de gallium-indium (InGaN) carbure de silicium (SiC)
Violet | 400 < λ < 450 | 2,76 < ΔV < 3,1 |
Ultraviolet | λ < 400 | ΔV > 3,1 | diamant (C) nitrure d'aluminium (AlN) nitrure d'aluminium-gallium (AlGaN)
Blanc | Chaude à froide | ΔV = 3,5 |

Pour le blanc, on ne parle pas de longueur d’onde mais de température de couleur proximale. Celle des diodes électroluminescentes est assez variable en fonction du modèle.

Câblage et alimentation électrique[ | ]

Les diodes électroluminescentes sont polarisées : on raccordera le pôle « - » à la cathode « - » et donc le pôle « + » à l'anode « + ». Les diodes à dôme basse puissance ont généralement trois détrompeurs : la cathode est plus courte, l'électrode à l'intérieur du dôme est plus grosse et le bord extérieur du dôme est plat. Inversement, l'anode est plus longue, l'électrode à l'intérieur du dôme est plus petite et le bord extérieur du dôme est arrondi (dessins en haut de page).

  • Gros-plan d'une diode électroluminescente.

  • L'anode et la cathode d'une LED. Les signes indiquent la polarisation (courant conventionnel) lorsque la diode est utilisée en sens direct.

Cliquez sur une vignette pour l’agrandir.

Sur tous les modèles et pour toutes les puissances, il est indispensable de ne pas dépasser l’intensité admissible (typiquement : 10 à 30 mA pour une LED de faible puissance et de l'ordre de 350 à 1 000 mA pour une LED de forte puissance).

Donc il faut intercaler un circuit limiteur de courant, souvent une résistance en série pour les faibles puissances. Utiliser les données du fabricant pour calculer la résistance en fonction de cette intensité désirée I, de Valim la tension d’alimentation, de VLED la tension directe de la LED et du nombre n de LED en série (loi d'Ohm : R = (Valim - n × VLED) / I). On peut regrouper plusieurs diodes dans un schéma série ou série-parallèle : les tensions directes s’additionnant en mode série; ce qui permet de diminuer la résistance en série et donc d’augmenter le rendement du dispositif. Le courant maximal admissible est lui multiplié par le nombre de diodes en parallèle.

Une méthode peu dispendieuse en énergie et adaptée aux plus forte puissances, consiste à utiliser un circuit de régulation du courant basé sur des principes analogues à ceux mis en œuvre dans les alimentations électriques à découpage. Cette méthode est employée pour les lampes LED d’éclairage, le circuit est intégré dans les culots des lampes.

Il est également primordial d'apporter un soin particulier à l'alimentation électrique des LED pour conserver leurs caractéristiques colorimétriques (température de couleur proximale, IRC…)[37].

Points forts et faiblesses[ | ]

Article connexe : Lampe à diode électroluminescente.

Avantages[ | ]

  • Petite taille : on peut par exemple construire des LED de la taille d'un pixel (ce qui ouvre la possibilité d'utiliser des diodes pour construire des écrans de haute résolution)
  • Facilité de montage sur un circuit imprimé, traditionnel ou CMS (Composant Monté en Surface).
  • Consommation inférieure aux lampes à incandescence et du même ordre de grandeur que les tubes fluorescents
  • Excellente résistance mécanique (chocs, écrasement, vibrations).
  • Taille beaucoup plus réduite que les lampes classiques ce qui offre la possibilité de réaliser des sources de lumière très ponctuelles, de faible à très faible consommation électrique (quelques dizaines de milliwatts) et avec un bon rendement. En assemblant plusieurs LED, on peut réaliser des éclairages avec des formes novatrices.
  • Durée de vie (20 000 à 50 000 heures environ) beaucoup plus longue qu’une lampe à incandescence (1 000 heures) ou qu'une lampe halogène (2 000 heures), mais du même ordre de grandeur que les lampes fluorescentes (5 000 à 70 000 heures). Les lampes puissantes voient leur durée de vie limitée, mais pouvant néanmoins atteindre 10 000, voire 15 000 heures selon le type d'utilisation qui en est fait[38],[39].
  • Fonctionnement en très basse tension (TBT), gage de sécurité et de facilité de transport. Il existe pour les campeurs des lampes de poche à LED actionnées par une simple dynamo à main (« lampe à manivelle ») de mouvement lent.
  • Atout non négligeable en matière de sécurité, par rapport aux systèmes lumineux classiques, leur inertie lumineuse est quasiment nulle. Elles s’allument et s’éteignent en un temps très court, ce qui permet l’utilisation en transmission de signaux à courte distance (optocoupleurs) ou longue (fibres optiques). Les LED atteignent immédiatement leur intensité lumineuse nominale.
  • Vu leur puissance, les LED classiques 5 mm ne chauffent presque pas et ne brûlent pas les doigts. Pour les montages de puissance supérieure à 1 W, il faut prévoir une dissipation de la chaleur, sans quoi la diode sera fortement endommagée, voire détruite du fait de l’échauffement. En effet, une diode électroluminescente convertit environ 20 % de l’énergie électrique en lumière, le reste étant dégagé sous forme de chaleur.
  • Les LED RVB (rouge-vert-bleu) permettent des mises en valeur colorées avec des possibilités de variations sans limite.

Inconvénients[ | ]

Spectre du rayonnement émis par une lampe à LED blanche
  • L'indice de rendu de couleur (IRC) s'est amélioré depuis 2010. Les LED dites blanches sont généralement des LED bleues ou émettant dans l'UV dont une partie de la lumière produite est transformée par fluorescence en lumière jaune au moyen d'un luminophore qui est souvent un grenat d'yttrium et d'aluminium dopé par des ions de terres rares tels que le cérium trivalent Ce3+ (d'autres matériaux luminescents pouvant être utilisés pour produire un blanc plus chaud)[40],[41] : le spectre est moins régulier que celui d'une lampe halogène. Plus rarement, le blanc est obtenu au moyen de trois diodes de couleurs différentes.
  • Les LED, comme tout composant électronique, ont des limites maximales de température de fonctionnement, de même que certains composants passifs constitutifs de leur circuit d'alimentation (comme les condensateurs chimiques qui s'échauffent en fonction du courant efficace), ce qui conditionne en partie la durée de vie des lampes à LED. La dissipation thermique des composants des ampoules à LED est un facteur limitant leur montée en puissance notamment en assemblages multipuces[42]. Les recherches portent sur des moyens de limiter la température et de mieux dissiper la chaleur des LED de puissance (par exemple pour des lampadaires ou phares automobiles)[42],[43].
  • Selon le constructeur Philips, l'efficacité lumineuse de certaines LED baisse rapidement (comme pour la plupart des technologies lumineuses) pour ne plus produire en fin de vie que 20 % de la quantité de lumière initiale, mais pour les LED les plus performantes du marché, la quantité de lumière produite en fin de vie serait encore d'au moins 70 %[44]. La température accélère la baisse de l'efficacité lumineuse. Philips précise également que la couleur peut varier sur certaines LED blanches et tirer sur le vert en vieillissant[45].
  • Le processus de fabrication d'une LED est très coûteux en énergie[réf. nécessaire] (mais une production à grande échelle comme actuellement permet de réduire massivement ce coût).

Perspectives[ | ]

En octobre 2016, le Laboratoire d'électronique et de technologie de l'information (LETI) et son voisin, l'Institut des nanosciences et cryogénie (INAC) ont reçu le prix EARTO Innovation Awards (European association of research and technology organisations) dans la catégorie « Impact attendu » pour leur mise au point d'une diode électroluminescente quatre fois moins chère à produire et produisant trois fois plus de lumière[46],[47],[48].

Utilisations[ | ]

Différents types de LED.
Costume LED.

Familles[ | ]

Il existe plusieurs manières de classer les diodes semi-électroluminescentes :

Classement selon la puissance[ | ]

La première est un classement par puissance :

  • les diodes électroluminescentes de faible puissance < 1 W. Ce sont les plus connues du grand public car elles sont présentes dans notre quotidien depuis des années. Ce sont elles qui jouent le rôle de voyant lumineux sur les appareils électroménagers par exemple ;
  • les LED de forte puissance > 2 W. Elles sont en plein essor et leurs applications sont de plus en plus connues du grand public : flash de téléphones portables, éclairage domestique, éclairage de spectacle, lampe de poche ou frontales… Le principe de fonctionnement est identique. Certaines différences significatives existent entre les deux familles, consacrées chacune à un champ d’application spécifique.

Classement selon le spectre d'émission[ | ]

Une autre manière de les classer est de considérer la répartition de l'énergie dans la gamme de longueur d'onde couvrant le visible (longueurs d'onde de l'ordre de 380 à 780 nm) ou l'invisible (principalement l'infrarouge). La raison de la distinction réside dans le fait que certaines diodes peuvent servir à éclairer, ce qui est l’une des applications phares du futur (proche) :

  • les chromatiques : l'énergie est concentrée sur une plage étroite de longueur d'onde (20 à 40 nm). Ces sources ont un spectre quasiment monochromatique ;
  • les blanches : l'énergie est répartie dans le visible sur toute la gamme de longueurs d'onde (380 à 780 nm environ) ;
  • les infrarouges : l'énergie est émise hors du spectre de la lumière visible (au-delà de 700 nm de longueur d'onde). Elles sont utilisées pour transmettre des signaux de télécommandes ou pour de la télémesure exploités par exemple dans la détection de position des consoles de jeux telles que la Wii, ou servir d'éclairage pour les caméras infrarouge, etc.

Autres classements[ | ]

D'autres classements sont possibles, par exemple selon le caractère monopuce ou multipuce, la durée de vie, la consommation d'énergie ou encore la robustesse en cas de sollicitations sous contraintes (comme pour certains matériels industriels, militaires, spatiaux…)

Diodes électroluminescentes ordinaires[ | ]

Éclairage[ | ]

Ampoule LED allumée
Ampoule LED
  • Signalisation routière, feux arrière de voitures ou de bicyclettes.
  • Signalisation ferroviaire.
  • Éclairage invisible pour caméras de surveillance (dans l’infrarouge).
  • Luminaires et éclairage urbain (plus récemment), avec par exemple Los Angeles, première métropole qui a remplacé ses 140 000 ampoules d'éclairage urbain par des diodes électroluminescentes de 2009 à 2014, ce qui devrait réduire de l'équivalent de 40 500 tonnes de carbone les émissions annuelles de cette ville (soit l'équivalent des émissions de 6 700 voitures)[49]. Après le remboursement de l'investissement, la ville pense aussi diminuer ses charges d'éclairage en économisant annuellement 10 millions de dollars[49].

Affichage[ | ]

  • Signalisation d’état d’appareils divers (lampes témoins en face avant ou sur le circuit, tableaux de bord de voitures, équipements de sécurité).
  • Affichage alphabétique ou numérique d’appareils de mesure, de calculatrices, d’horloges.
  • Affichages de niveaux de mesures (niveaux de cuves, VU-mètres).
  • Affichage statique ou dynamique de messages (journaux lumineux).

Source de lumière quasi monochromatique[ | ]

  • Photocoupleur.
  • Transmission de signaux par fibre optiques.
  • Télécommandes (LED infrarouges).
  • Cellules photoélectriques (LED infrarouges).
  • Faisceau laser pour les appareils de mesure.
  • Faisceau laser pour la lecture et la gravure des CD et DVD.
  • Luminothérapie contre l'acné.

Diodes électroluminescentes blanches[ | ]

L'amélioration du rendement des LED permet de les employer en remplacement de lampes à incandescence ou fluorescence, à condition de les monter en nombre suffisant :

  • LED noyées dans le bitume pour la matérialisation des pistes la nuit ou par temps de brouillard ;
  • signalisation portative individuelle (piéton, cycliste) ;
  • éclairages de secours ;
  • éclairage de courte portée portatif ;
  • feux de signalisation automobile ou motocycliste (clignotant, veilleuses, feux de position) ;
  • signalisation ferroviaire (feu blanc, feu blanc clignotant et œilleton notamment, sur le réseau ferré national) ;
  • éclairage stroboscopique ;
  • lampes de poche à piles ou accumulateur à génératrice de recharge incorporé ;
  • lampes de balisage des jardins alimentées par panneau solaire.

En 2006, le groupe américain Graffiti Research Lab a lancé un mouvement nommé Led throwies (lancer de LED) qui consiste à égayer les lieux publics en ajoutant de la couleur sur des surfaces magnétiques. Pour ceci, on combine une LED, une pile au lithium et un aimant, et on lance l’ensemble sur une surface magnétique[50].

Les LED sont utilisées pour réaliser des écrans vidéo de très grande taille (plateaux TV salon dans des grands halls, stade…).

Le rétroéclairage de l’écran par des diodes électroluminescentes permet de fabriquer des écrans plus fins, plus lumineux, ayant une étendue colorimétrique plus importante et plus économes que son prédécesseur ACL à rétroéclairage par tube fluorescent (technologie CCFL).[réf. nécessaire]

Essor des LED[ | ]

En 2007, Audi et Lexus bénéficient de dérogations de la Commission européenne pour commercialiser des modèles munis de feux avant à base de LED. En 2009, la Ferrari 458 Italia innove elle aussi avec des phares à LED.

Plusieurs villes remplacent leur éclairage public par des LED dans le but de diminuer leur facture d’électricité et la pollution lumineuse du ciel (éclairage dirigé vers le bas). Le recours aux LED est aussi courant dans les feux tricolores. L’exemple de Grenoble est le plus souvent cité : la ville a réalisé son retour sur investissement en trois ans seulement. En effet, les LED permettent des économies d’énergie, mais ce sont surtout les coûts de maintenance qui baissent, du fait de leur robustesse.

En 2010, La RATP expérimente l'éclairage des espaces du métro parisien, notamment à la station Censier-Daubenton première station de métro entièrement éclairée par cette technologie. En 2012 estimant le produit mature la RATP (réseau de transport en commun de Paris) décide de la totalité de son éclairage vers la technologie LED. C'est plus de 250 000 luminaires qui seront modifiés, faisant ainsi du métro parisien le premier réseau de transport en commun d'envergure à adopter le « tout LED »[51]. Le remplacement des éclairages est finalisé en 2016


LED Technical Specifications and Application Notes

Vu dans ... http://www.theledlight.com/technical1.html

LED Application Notes - LED Basics

Eye Protection - LEDs are very bright. DO NOT look directly into the LED light. The light can be intense enough to injure human eyes.
Technical Index

How does a LED work?

This is a very simple explanation of the construction and function of LEDs. White LEDs need 3.6VDC and use approximately 30 milliamps of current, a power dissipation of 100 milliwatts. The positive power is applied to one side of the LED semiconductor through a lead (1 anode) and a whisker (4). The other side of the semiconductor is attached to the top of the anvil (7) that is the negative power lead (2 cathode). It is the chemical makeup of the LED semiconductor (6) that determines the color of the light the LED produces. The epoxy resin enclosure (3 and 5) has three functions. It is designed to allow the most light to escape from the semiconductor, it focuses the light (view angle), and it protects the LED semiconductor from the elements. As you can see, the entire unit is totally embedded in epoxy. This is what make LEDs virtually indestructible. There are no loose or moving parts within the solid epoxy enclosure.

Therefore, a light-emitting diode (LED) is essentially a PN junction semiconductor diode that emits light when current is applied. By definition,
it is a solid-state device that controls current without heated filaments and is therefore very reliable.
LED performance is based on a few primary characteristics:

LED Colors

LEDs are highly monochromatic, emitting a pure color in a narrow frequency range. The color emitted from an LED is identified by peak wavelength (lpk) and measured in nanometers (nm ).

Peak wavelength is a function of the LED chip material. Although process variations are ±10 NM, the 565 to 600 NM wavelength spectral region is where the sensitivity level of the human eye is highest. Therefore, it is easier to perceive color variations in yellow and amber LEDs than other colors.

LEDs are made from gallium-based crystals that contain one or more additional materials such as phosphorous to produce a distinct color. Different LED chip technologies emit light in specific regions of the visible light spectrum and produce different intensity levels

White LED Light

When light from all parts of the visible spectrum overlap one another, the additive mixture of colors appears white. However, the eye does not require a mixture of all the colors of the spectrum to perceive white light. Primary colors from the upper, middle, and lower parts of the spectrum (red, green, and blue), when combined, appear white. To achieve this combination with LEDs requires a sophisticated electro-optical design to control the blend and diffusion of colors. Variations in LED color and intensity further complicate this process.

Presently it is possible to produce white light with a single LED using a phosphor layer (Yttrium Aluminum Garnet) on the surface of a blue (Gallium Nitride) chip. Although this technology produces various hues, white LEDs may be appropriate to illuminate opaque lenses or backlight legends. However, using colored LEDs to illuminate similarly colored lenses produces better visibility and overall appearance.

Intensity

LED light output varies with the type of chip, encapsulation, efficiency of individual wafer lots and other variables. Several LED manufacturers use terms such as "super-bright," and "ultra-bright" to describe LED intensity. Such terminology is entirely subjective, as there is no industry standard for LED brightness. The amount of light emitted from an LED is quantified by a single point, on-axis luminous intensity value (Iv). LED intensity is specified in terms of millicandela (mcd). This on-axis measurement is not comparable to mean spherical candlepower (MSCP) values used to quantify the light produced by incandescent lamps.

Luminous intensity

is roughly proportional to the amount of current (If) supplied to the LED. The greater the current, the higher the intensity. Of course, there are design limits. Generally, LEDs are designed to operate at 20 milliamps (mA). However, operating current must be reduced relative to the amount of heat in the application. For example, 6-chip LEDs produce more heat than single-chip LEDs. 6-chip LEDs incorporate multiple wire bonds and junction points that are affected more by thermal stress than single-chip LEDs. Similarly, LEDs designed to operate at higher design voltages are subject to greater heat. LEDs are designed to provide long-life operation because of optimal design currents considering heat dissipation and other degradation factors.

Eye Safety Information

The need to place eye safety labeling on LED products is dependent upon the product design and the application. Only a few LEDs produce sufficient intensity to require eye safety labeling. However, for eye safety, do not stare into the light beam of any LED at close range

Visibility

Luminous intensity (Iv) does not represent the total light output from an LED. Both the luminous intensity and the spatial radiation pattern (viewing angle) must be taken into account. If two LEDs have the same luminous intensity value, the lamp with the larger viewing angle will have the higher total light output.

Theta one-half (q½) is the off-axis angle where the LED's luminous intensity is half the intensity at direct on-axis view. Two times q½ is the LEDs' full viewing angle; however, light emission is visible beyond the q½ point. Viewing angles listed in this catalog are identified by their full viewing angle (2q½ °).

LED viewing angle is a function of the LED chip type and the epoxy lens that distributes the light. The highest luminous intensity (mcd rating) does not equate to the highest visibility. The light output from an LED chip is very directional. A higher light output is achieved by concentrating the light in a tight beam. Generally, the higher the mcd rating, the narrower the viewing angle.

The shape of the encapsulation acts as a lens magnifying the light from the LED chip. Additionally, the tint of the encapsulation affects the LED's visibility. If the encapsulation is diffused, the light emitted by the chip is more dispersed throughout the encapsulation. If the encapsulation is non-diffused or water clear, the light is more intense, but has a narrower viewing angle. Non-diffused and water clear LEDs have identical viewing angles; the only difference is, water clear encapsulations do not have a tint to indicate color when the LED is not illuminated.

Overall visibility can be enhanced by increasing the number of LED chips in the encapsulation, increasing the number of individual LEDs, and utilizing secondary optics to distribute light. To illustrate, consider similar red GaAlAs LED chip technology in four different configurations:

In each case, the amount of visible light depends on how the LED is being viewed. The single chip may be appropriate for direct viewing in competition with high ambient light. The 6-chip may be better suited to backlight a switch or small legend, while the cluster or lensed LED may be best to illuminate a pilot light or larger lens.

Operating Life

Because LEDs are solid-state devices they are not subject to catastrophic failure when operated within design parameters. DDP® LEDs are designed to operate upwards of 50,000 hours at 25°C ambient temperature. Operating life is characterized by the degradation of LED intensity over time. When the LED degrades to half of its original intensity after 50,000 hours it is at the end of its useful life although the LED will continue to operate as output diminishes. Unlike standard incandescent bulbs, DDP® LEDs resist shock and vibration and can be cycled on and off without excessive degradation.

Voltage/Design Current

LEDs are current-driven devices, not voltage driven. Although drive current and light output are directly related, exceeding the maximum current rating will produce excessive heat within the LED chip due to excessive power dissipation. The result will be reduced light output and reduced operating life. LEDs that are designed to operate at a specific voltage contain a built-in current-limiting resistor. Additional circuitry may include a protection diode for AC operation or full-bridge rectifier for bipolar operation. The operating current for a particular voltage is designed to maintain LED reliability over its operating life.

Precautions While Working With LEDs

General

We cannot assume any responsibility for any accident or damage caused when the products are used beyond the maximum ratings specified herein. These pages are for information only and are the user assumes all responsibility and risk.

The user of these products must confirm the performance of the LEDs after they are actually assembled into the user's products/systems. It is strongly advised that he user design fail-safe products/systems. We will not be responsible for legal matters which are caused by the malfunction of these products/systems.

Static Electricity and Surge

Static electricity and surge damage LEDs. It is recommended to use a wrist band or anti-electrostatic glove when handling the LEDs. All devices, equipment and machinery must be electrically grounded.

LEAD Forming:

The leads should be bent at a point at least 3mm from the epoxy resin of the LEDs.Bending should be performed with the base firmly fixed by means of a jig or radio pliers.

Mounting Method:

The leads should be formed so they are aligned exactly with the holes on the PC board. This will eliminate any stress on the LEDs.

Use LEDs with stoppers or resin spacer to accurately position the LEDs. The epoxy resin base should not be touching the PC board when mounting the LEDs. Mechanical stress to the resin may be caused by the warping of the PC board when soldering. The LEDs must not be designed into a product or system where the epoxy lens is pressed into a plastic or metal board. The lens part of the LED must not be glued onto plastic or metal. The mechanical stress to the leadframe must be minimized.<,p>

Soldering

Solder the LEDs no closer than 3mm from the base of the epoxy resin.For solder dipping, it may be necessary to fix the LEDs for correct positioning. When doing this, any mechanical stress to the LEDs must be avoided.

When soldering, do not apply any mechanical force to the leadframe while heating.Repositioning after soldering must be avoided.

Cleaning

Avoid exposure to chemicals as they may attack the LED surface and cause discoloration. When washing is required, "isopropyl alcohol" is to be used.

The influence of ultrasonic cleaning on the LEDs differs depending on factors such as oscillator output and the way in which the LEDs are mounted. Therefore, ultrasonic cleaning should only be performed after making certain that it will not cause any damage.

Emission color

LED emission wavelengths vary. LEDs are classified by emission color into different ranks. When a large volume of LEDs are purchased, LEDs with different color ranks will be delivered

Packaging

The leadframes of the LEDs are coated with silver. Care must be taken to maintain a clean storage atmosphere. If the LEDs are exposed to gases such as hydrogen sulfide, it may cause discoloration of the leadframes. Moistureproof packing is used to keep moisture away from the chip type LEDs. When storing chip type LEDs, please use a sealable package with a moisture absorbent material inside.

LED Cluster Lamp and LED Dot Matrix Unit

Assembly

Please refer to the recommended distance between the leads when designing lead holes on the PC board.Close attention must be paid on the correct positioning of O-rings and other water proof seals when assembling products/systems.

LEDs are vulnerable to static electricity. When handling the LEDs, necessary precautions regarding static electricity must always be taken into consideration.

Installation of LEDs

Make certain that the lead position and polarity are correct when installing the LEDs.The interface cable must be as short as possible.

The power supply and ground line must be selected according to their current capacity.

Heat Dissipation

When many LEDs are mounted into a small area, heat generation must be taken into consideration. If there is a possibility that the ambient temperature may exceed 60 degrees centigrade, some kind of forced cooling system will be needed.

The ambient operating temperature must be taken into consideration when a product/ system is being designed. There are certain limits to maximum current, at certain temperatures which must be kept in mind.

Handling

When the surface of the LEDs must be cleaned, the LEDs should be wiped softly with detergent. The surface may be damaged and the effect of the lens may be reduced with violent scrubbing.

Others

EMI countermeasures must be taken as a system.

When instantaneous power failure, or a current surge by lightning stops the controller at abnormal conditions, the abnormally high electric current may continue running through the LEDs for an extended period of time. This can damage the LEDs in the system. Circuit protection against abnormally high current must be built into the system to protect against this.

Copyright: Data Display Products 01/01/00

Disclaimer: The information provide herein are basics to educate one on the operating properties and user characteristics of LEDs. We do not imply that the information is accurate or applicable to every aspect of LED usage. Each application will have to be performed on its own merits and with full understanding that damages and injury are the sole responsibility of the "builder". We do not dispense engineering advice. You need to determine the specific products you will need for your specific application.


Basic Light Emitting Diode guide - DP

Vu dans ... http://dangerousprototypes.com/docs/Basic_Light_Emitting_Diode_guide

Basic Light Emitting Diode guide

Contents

[hide]
  • 1 Overview
  • 2 What is a Light Emitting Diode?
  • 3 Anode and cathode ends
  • 4 Voltage drop or forward voltage
  • 5 Forward Current rating
  • 6 Basic LED Circuit
  • 7 Conclusion

Overview

Probably the most used device in our projects is the humble LED. They’re used in almost every piece of equipment around us. While LEDs are simple to use, we get a surprising number of requests for a LED tutorial. This guide is an introduction to LEDs. Not just how to light them, but how to mine a datasheet for the key values and plug them into an equation! Also check out the evolving version on the tutorials wiki.

If you’re too lazy to calculate the proper resistance value for every LED – like we are – here’s what we use for one-off prototypes:

  • For a 3.3 volt supply use a 2K resistor
  • For a 5.0 volt supply use a 10K resistor

There, no need to read further. If you insist on doing it the proper way, looking stuff up in datasheets, read on.

What is a Light Emitting Diode?

Image by S-kei: CC BY-SA

A light emitting diode consists of two pieces of semiconductor. One P-type with positively charged “holes”, and one N-type with negatively charged electrons.

When the P side is connected to power, and N to ground, (forward biased P->N direction) current flows through the diode. The electrons and holes combine, neutralizing each other. This releases energy in the form of light, pretty blue (or whatever) LEDness.

The energy is released at a constant wave-length which dictates the color of an LED.

Anode and cathode ends

The anode is the P-type semiconductor end of a diode. Current flows into it and exits through the Cathode. It is always the base of the triangle in the diode symbol. LEDs will light up only when connected the right way around, otherwise they pretty much act as an open circuit (like nothing is connected at all).

Voltage drop or forward voltage

Voltage drop across an LED, also known as forward voltage, tells you how many volts are needed to light it up. Some typical values are listed here, but the best thing to do is get a datasheet and search for the exact Vf value of your part.

As an exercise grab this Kingbright 0805 chip red LED datasheet, and jump to page 2 where the forward voltage Vf is located. In this example the RED chip LED has a Vf of 2 volts. You could power it from a 3.3 volt supply. You could gang together two, cathode to anode, and run them from a 5 volt supply. ( as shown below)

The Vf value is key to calculating the correct current limiting resistor in a future step. Stay tuned!

Forward Current rating

Most LEDs are designed to work best, and have a long happy life, at a specific current. Typically 20mA for common LEDs, but there’s endless other LEDs out there too. Best to check for If in the datasheet. In the datasheet we provided above, the If is 20mA.

As long as you set your current around or below this number your LED should be safe. This rule can be violated if you pulse the LED, giving the die time to cool. For example a 20mA LED blinking on 50% of the time could be run at 40mA.

Basic LED Circuit

LED basic setp.jpg

Here we have a power source V, a current limiting resistor R, and an LED with a voltage drop Vd. The resistor is required to limit the current through the LED at, or below, the datasheet specified forward current If.

Calculating the current limiting resistor in a single LED circuit.

R=(V-Vd)/Id

To calculate the resistance for your circuit subtract the voltage drop from the supply voltage and divide by the desired current.

Probably the absolute easiest way to calculate the resistance is to use a online calculator like the LED calculator for single LEDs, Parallel LED Resistor Calculator, LED Series Resistance Calculator. For the nitty gritty continue below.

Id is the current you want to use on your LED, usually the forward current. Keep in mind that resistors come in specific values, so select the one closest (higher than) to the value given by the formula.

R=(3.3V-2V)/20mA=1.3V/20mA=65 Ohm

Our example uses values extracted from Kingbright’s 0805 chip red LED datasheet. It states the LED’s typical forward voltage is 2V. From the same datasheet the optimal forward current If is 20mA. Using the formula above for calculating the resistor value we find that we need a resistor of 65 Ohms.

Now 65 Ohms is not a standard resistor value. The next closest value is 68 Ohm, and this will give you 19.1mA. .

R=(5V-2V)/20mS = 3V/20mA=150 Ohm

Now lets do the same for a 5 volt supply. In this case 150 Ohms is a standard resistor value, so there is no need to look further.

You might have noticed that these values are much smaller then the rule of thumb values we gave earlier. This is because we don’t want the LEDs to be at full brightness. It’s often distracting to users.

Calculating the current limiting resistor for multiple LEDs connected in parallel

Connecting multiple LEDs in parallel is usually a bad idea. Even LEDs of the same production series have slightly different forward voltage to forward current ratios. Some LEDs will draw more current, and some less. This leads to differences in brightness between the LEDs that could reduce the useful life.

R = (V-Vd)/(n*Id)

Where n is the number of LEDs connected this way, and Id is the forward current of a single LED.

R=(3.3V-2V)/(4*20mA)=1.3V/80mA=16.25 Ohm

Let's use the same LED as before in this example where 4 LEDs are connected in parallel. The resistance calculated is 16.25 Ohms, which is not standard. The next standard resistor value is 18 Ohms. This gives you 18.1mA across each LED. As mentioned above this will vary from LED to LED.

R=(5V-2V)/(4*20mA)=3V/80mA=37.5 Ohm

Here is the same setup, but with a 5V supply. This time requiring a non-standard 37.5 Ohms resistor. The next standard value is 39 Ohms. This gives you 19.2mA across each LED.

Worth noting is that in case a single LED burns out, the total current will remain the same. It will be distributed between the LEDs, thus putting more stress on them.

Calculating the current limiting resistor for multiple LEDs connected in series

LEDs can also be connected in series, the cathode of one LED connected to the anode of the next. This is done when you have access to a higher voltage power supply, and is more commonly used than the parallel arrangement above. The same current flows through the entire strand of LEDs, thus ensuring they are all the same brightness.

R=(V-(n*Vd))/Id

Use the following formula to calculate the resistance for the current needed. Since the LEDs are connected in series, the entire voltage drop is equal to all the voltage drops added together (n*Vd).

R=(12V-(4*2V))/20mA=(12V-8V)/20mA=4V/20mA= 200 Ohms

Lets use 4 LEDs connected in series with the same specs as before in our example. Obviously the supply voltage will have to be higher then 3.3V, or even 5V, so we chose 12V for this example.

The calculated resistor value is 200 Ohms, which oddly enough is not standard. The next standard resistor value is 220 Ohms, and this will give us 18.2mA going through all the LEDs.

Keep in mind that your power supply needs to be larger then the combined voltage drop of all the LEDs.

In case an LED fails in this setup, the circuit is broken, and all LEDs stop shining.

Conclusion

LEDs are simple, and a fairly universal first electronics project. To calculate the correct current limiting resistor find the forward current and voltage in the datasheet and follow the guide. If you can’t be bothered, just use our rule of thumb for prototype board LEDs:

  • For a 3.3 volt supply use a 2K resistor
  • For a 5.0 volt supply use a 10K resistor


LED circuit - Wikipedia

Vu dans ... https://en.wikipedia.org/wiki/LED_circuit

LED circuit

From Wikipedia, the free encyclopedia

In electronics, an LED circuit or LED driver is an electrical circuit used to power a light-emitting diode (LED). The circuit must provide sufficient current to light the LED at the required brightness, but must limit the current to prevent damaging the LED. The voltage drop across an LED is approximately constant over a wide range of operating current; therefore, a small increase in applied voltage greatly increases the current. Very simple circuits are used for low-power indicator LEDs. More complex, current source circuits are required when driving high-power LEDs for illumination to achieve correct current regulation.

Basic circuit

The simplest circuit to drive an LED is through a series resistor. Although simple, this circuit is not the most energy efficient circuit to drive an LED, since energy is lost in the resistor. More complicated circuits improve the energy efficiency.

An LED has a voltage drop specified at the intended operating current. Ohm's law and Kirchhoff's circuit laws are used to calculate the appropriate resistor value to obtain the desired current. The value is computed by subtracting the LED voltage drop from the supply voltage and dividing by the desired operating current.

If the supply voltage is close or equal to the LED forward voltage, then no reasonable value for the resistor can be calculated. An LED should not be operated without some form of current limiting. If the supply voltage is close to the forward voltage of the LED, then a better method of current limiting must be used - a series resistor cannot be used in these conditions.

This basic circuit is used in a wide range of applications, including many consumer appliances such as mobile phone chargers.

Power source considerations

The voltage versus current characteristics of an LED are similar to any diode. Current is approximately an exponential function of voltage according to the Shockley diode equation, and a small voltage change may result in a large change in current. If the voltage is below or equal to the threshold no current flows and the result is an unlit LED. If the voltage is too high the current exceeds the maximum rating, overheating and potentially destroying the LED.

As an LED heats up, its voltage drop decreases (band gap decrease This can encourage the current to increase.

It is therefore important that the power source provides an appropriate current. LEDs should only be connected to constant-current sources. Series resistors are a simple way to passively stabilize the LED current. An active constant current regulator is commonly used for high power LEDs, stabilizing light output over a wide range of input voltages which might increase the useful life of batteries. Low drop-out (LDO) constant current regulators also allow the total LED voltage to be a higher fraction of the power supply voltage. Switched-mode power supplies are used in some LED flashlights and household LED lamps.

Series resistor [ edit ]

Series resistors are a simple way to stabilize the LED current, but energy is wasted in the resistor.

Miniature indicator LEDs are normally driven from low voltage DC via a current-limiting resistor. Currents of 2 mA, 10 mA and 20 mA are common. Sub-mA indicators may be made by driving ultrabright LEDs at very low current. Efficiency tends to reduce at low currents, but indicators running on 100 μA are still practical.

In coin cell powered keyring-type LED lights, the resistance of the cell itself is usually the only current limiting device. The cell should not therefore be replaced with a lower resistance type.

LEDs can be purchased with built-in series resistors. These can save printed circuit board space and are especially useful when building prototypes or populating a PCB in a way other than its designers intended. However, the resistor value is set at the time of manufacture, removing one of the key methods of setting the LED's intensity.

Series resistor calculation

The formula to calculate the correct resistance to use is

where Vs is the power supply voltage, e.g. a 9-volt battery; Vf is the LED forward voltage (also referred to as the "voltage drop") across the LED; and I is the desired current of the LED. Both Vf and the maximum recommended value for I are obtained from the LED manufacturer's specifications. The above formula requires the current in amperes, although this is usually given by the manufacturer in milliamperes, such as 20 mA. Many circuits operate LEDs at less than the recommended maximum current, to save power, to permit the use of a standard resistor value, or to reduce brightness.

Typically, the forward voltage of an LED is between 1.8 and 3.3 volts. It varies by the color of the LED. A red LED typically drops 1.8 volts, but since both voltage drop and light frequency increase with band gap, a blue LED may drop from 3 to 3.3 volts.

The formula is an application of Ohm's law in which the supply voltage is offset by the voltage drop across the diode, which varies little over the range of useful currents.

LED arrays

Strings of multiple LEDs are normally connected in series. In one configuration, the source voltage must be greater than or equal to the sum of the individual LED voltages; typically the LED voltages add up to around two-thirds of the supply voltage. A single current-limiting resistor may be used for each string.

Parallel operation is also possible but can be more problematic. Parallel LEDs must have closely matched forward voltages (Vf) in order to have similar branch currents and, therefore, similar light output. Variations in the manufacturing process can make it difficult to obtain satisfactory operation when connecting some types of LEDs in parallel.

LED orientation

LED display

Main article: LED display

LEDs are often arranged in ways such that each LED (or each string of LEDs) can be individually turned on and off.

Direct drive is the simplest-to-understand approach—it uses many independent single-LED (or single-string) circuits. For example, a person could design a digital clock such that when the clock displays "12:34" on a seven-segment display, the clock would turn on the appropriate segments directly and leave them on until something else needs to be displayed.

However, multiplexed display techniques are more often used than direct drive, because they have lower net hardware costs. For example, most people who design digital clocks design them such that when the clock displays "12:34" on a seven-segment display, at any one instant the clock turns on the appropriate segments of one of the digits—all the other digits are dark. The clock scans through the digits rapidly enough that it gives the illusion that it is "constantly" displaying "12:34" for an entire minute. However, each "on" segment is actually being rapidly pulsed on and off many times a second.

An extension of this technique is Charlieplexing where the ability of some microcontrollers to tri-state their output pins means larger numbers of LEDs can be driven, without using latches. For N pins, it is possible to drive n2-n LEDs.

Polarity

Unlike incandescent light bulbs, which illuminate regardless of the electrical polarity, LEDs will only light with correct electrical polarity. When the voltage across the p-n junction is in the correct direction, a significant current flows and the device is said to be forward-biased. If the voltage is of the wrong polarity, the device is said to be reverse biased, very little current flows, and no light is emitted. LEDs can be operated on an alternating current voltage, but they will only light with positive voltage, causing the LED to turn on and off at the frequency of the AC supply.

Most LEDs have low reverse breakdown voltage ratings, so they will also be damaged by an applied reverse voltage above this threshold. The cause of damage is overcurrent resulting from the diode breakdown, not the voltage itself. LEDs driven directly from an AC supply of more than the reverse breakdown voltage may be protected by placing a diode (or another LED) in inverse parallel.

The manufacturer will normally advise how to determine the polarity of the LED in the product datasheet.

Pulsed LED operation

Many systems pulse LEDs on and off, by applying power periodically or intermittently. So long as the flicker rate is greater than the human flicker fusion threshold, and the LED is stationary relative to the eye, the LED will appear to be continuously lit. Varying the on/off ratio of the pulses is known as pulse-width modulation. In some cases PWM-based drivers are more efficient than constant current or constant voltage drivers.

Most LED data sheets specify a maximum DC current that is safe for continuous operation. Often they specify some higher maximum pulsed current that is safe for brief pulses, as long as the LED controller keeps the pulse short enough and then turns off the power to the LED long enough for the LED to cool off.

LED as light sensor

Mobile phone IrDA

In addition to emission, an LED can be used as a photodiode in light detection. This capability may be used in a variety of applications including ambient light detection and bidirectional communications.

As a photodiode, an LED is sensitive to wavelengths equal to or shorter than the predominant wavelength it emits. For example, a green LED is sensitive to blue light and to some green light, but not to yellow or red light.

This implementation of LEDs may be added to designs with only minor modifications in circuitry. An LED can be multiplexed in such a circuit, such that it can be used for both light emission and sensing at different times.


Vu dans ... https://www.aurel32.net/elec/lcd.php

Les afficheurs à cristaux liquides

Introduction

Les afficheurs à cristaux liquides, autrement appelés afficheurs LCD (Liquid Crystal Display), sont des modules compacts intelligents et nécessitent peu de composants externes pour un bon fonctionnement. Ils consomment relativement peu (de 1 à 5 mA), sont relativement bons marchés et s'utilisent avec beaucoup de facilité.

Plusieurs afficheurs sont disponibles sur le marché et diffèrent les uns des autres, non seulement par leurs dimensions, (de 1 à 4 lignes de 6 à 80 caractères), mais aussi par leurs caractéristiques techniques et leur tension de service. Certains sont dotés d'un rétroéclairage de l'affichage. Cette fonction fait appel à des LED montées derrière l'écran du module, cependant, cet éclairage est gourmand en intensité (de 80 à 250 mA). Un afficheur LCD 2x16 caractères réflectif Un afficheur LCD 2x20 caractères rétroéclairé Un afficheur LCD 2x40 caractères rétroéclairé

Ils sont très utilisés dans les montages à microcontrôleur, et permettent une grande convivalité. Ils peuvent aussi être utilisés lors de la phase de développement d'un programme, car on peut facilement y afficher les valeurs de différentes variables.

Principe des cristaux liquides

L'afficheur est constitué de deux lames de verre, distantes de 20 µm environ, sur lesquelles sont dessinées les mantisses formant les caractères. L'espace entre elles est rempli de cristal liquide normalement réfléchissant (pour les modèles réflectifs). L'application entre les deux faces d'une tension alternative basse fréquence de quelques volts (3 à 5 V) le rend absorbant. Les caractères apparaissent sombres sur fond clair. N'émettant pas de lumière, un afficheur à cristaux liquides réflectif ne peut être utilisé qu'avec un bon éclairage ambiant. Sa lisibilité augmente avec l'éclairage. Les modèles transmissifs fonctionnent différemment: normalement opaque au repos, le cristal liquide devient transparent lorsqu'il est excité; pour rendre un tel afficheur lisible, il est nécessaire de l'éclairer par l'arrière, comme c'est le cas pour les modèles rétroéclairés.

Brochage

Un circuit intégré spécialisé est chargé de la gestion du module. Il remplit une double fonction : d'une part il commande l'affichage et de l'autre se charge de la communication avec l'exterieur.

Broche | Nom | Niveau | Fonction
1 | Vss | - | Masse
2 | Vdd | - | Alimentation positive +5V
3 | Vo | 0-5V | Cette tension permet, en la faisant varier entre 0 et +5V, le réglage du contraste de l'afficheur.
4 | RS | TTL | Selection du registre (Register Select) Grâce à cette broche, l'afficheur est capable de faire la différence entre une commande et une donnée. Un niveau bas indique une commande et un niveau haut indique une donnée.
5 | R/W | TTL | Lecture ou écriture (Read/Write) L : Écriture H : Lecture
6 | E | TTL | Entrée de validation (Enable) active sur front descendant. Le niveau haut doit être maintenue pendant au moins 450 ns à l'état haut.
7 | D0 | TTL | Bus de données bidirectionnel 3 états (haute impédance lorsque E=0)
8 | D1 | TTL
9 | D2 | TTL
10 | D3 | TTL
11 | D4 | TTL
12 | D5 | TTL
13 | D6 | TTL
14 | D7 | TTL
15 | A | - | Anode rétroéclairage (+5V)
16 | K | - | Cathode rétroéclairage (masse)

Les broches 15 et 16 ne sont présentes que sur les afficheurs LCD avec retroéclairage.

Les connexions à réaliser sont simples puisque l'afficheur LCD dispose de peu de broches. Il faut évidemment, l'alimenter, le connecter à un bus de donnée (4 ou 8 bits), et connecter les broches E, R/W et RS.

La mémoire

L'afficheur possède deux type de mémoire, la DD RAM et la CG RAM. La DD RAM est la mémoire d'affichage et la CG RAM est la mémoire du générateur de caractères.

La mémoire d'affichage (DD RAM)

La DD RAM est la mémoire qui stocke les caractères actuellement affiché à l'écran. Pour un afficheur de 2 lignes de 16 caractères, les adresses sont définies de la façon suivante :

Ligne | Visible | Invisible
Haut | 00H..........0FH | 10H..........27H
Bas | 40H..........4FH | 50H..........67H

L'adresse 00H correspond à la ligne du haut à gauche, 0FH à droite. L'adresse 40H correspond à la ligne du bas à gauche, 4FH à droite. La zone invisible correspond à la mémoire de l'afficheur (48 caractères). Lorsqu'un caractère est inscrit à l'adresse 27H, le caractère suivant apparaît à la ligne suivante.

La mémoire du générateur de caractères (CG RAM)

Le générateur de caractère est quelque chose de très utile. Il permet la création d'un maximum de 8 caractères ou symboles 5x7. Une fois les nouveaux caractères chargés en mémoire, il est possible d'y accéder comme s'il s'agissait de caractères classiques stockés en ROM.

La CG RAM utilise des mots de 8 bits de large, mais seul les 5 bits de poids faible apparaissent sur le LCD. Ainsi D4 représente le point le plus à gauche et D0 le point le polus à droite. Par exemple, charger un octet de la CG RAM à 1Fh fait apparaître tous les points de cette rangée ; charger un octet à 00h éteint tous ces points. Les 8 lignes d'un caractère doivent être chargées dans la CG RAM.

La CG RAM peut être utilisée pour créer des caractères en vidéo inversée, des caractères avec des accents, etc. La limitation d'un total de 8 caractères peut être contournée en utilisant une bibliothèque de 8 symboles résidant dans le système hôte. Un maximum de 8 caractères peut être affiché à la fois.

La CG RAM peut être rechargée periodiquement en fonction des besoins. Si un caractère de la CG RAM qui est actuellement sur l'afficheur est changé, alors le changement est immédiatemment apparent sur l'affficheur.

Commande d'un afficheur LCD

Deux modes de fonctionnement de l'afficheur sont disponibles, le mode 4 bits et le mode 8 bits, modes que l'on choisira à l'initialisation de l'afficheur (voir plus bas).

Mode 8 bits :

Dans ce mode 8 bits, les données sont envoyées à l'afficheur sur les broches D0 à D7. On place la ligne RS à 0 ou à 1 selon que l'on désire transmettre une commande ou une donnée. Il faut aussi placer la ligne R/W à 0 pour indiquer à l'afficheur que l'on désire effectuer une écriture. Il reste à envoyer une impulsion d'au moins 450 ns sur l'entrée E, pour indiquer que des données valides sont présentes sur les broches D0 à D7. L'afficheur lira la donnée sur le front descendant de cette entrée.

Si on désire au contraire effectuer une lecture, la procédure est identique, mais on place cette fois la ligne R/W à 1 pour demander une lecture. Les données seront valide sur les lignes D0 à D7 lors de l'état haut de la ligne E.

Mode 4 bits :

Il peut, dans certains cas, être nécessaire de diminuer le nombre de fils utilisés pour commander l'afficheur, comme, par exemple lorsqu'on dispose de très peu de broches d'entrées sorties disponibles sur un microcontrôleur. Dans ce cas, on peut utiliser le mode quatre bits de l'afficheur LCD. Dans ce mode, seuls les 4 bits de poids fort (D4 à D7) de l'afficheur sont utilisées pour transmettre les données et les lire. Les 4 bits de poids faible (D0 à D3) sont alors connectés à la masse. On a donc besoin, hors alimentation de sept fils pour commander l'afficheur. Les données sont alors écrites ou lues en envoyant séquentiellement les quatres bits de poids fort suivi des quatres bits de poids faible. Une impulsion positive d'au moins 450 ns doit être envoyée sur la ligne E pour valider chaque demi-octet ou nibble.

Dans les deux modes, on peut, après chaque action sur l'afficheur, vérifier que celui-ci est en mesure de traiter l'information suivrante. Pour cela, il faut demander une lecture en mode commande, et tester le flag Busy BF. Lorsque BF=0, l'afficheur est près à recevoir une nouvelle commande ou donnée.

Il se peut qu'on dispose encore de moins de broches disponibles dans l'application envisagée. Dans ce cas, on peut alors relier la ligne R/W à la masse de façon à forcer l'afficheur en écriture. On a alors besoin, hors alimentation de seulement six fils en mode 4 bits, et dix fils en mode 8 bits, pour commander l'afficheur, mais on ne peut alors plus relire l'afficheur. Ceci n'est pas gênant dans la mesure où on sait ce qu'on a écrit sur l'afficheur, mais on ne peut alors plus relire le flag Busy. Il faut alors utiliser des temporisations après chaque écriture sur l'afficheur. On perd alors un peu en temps d'affichage, mais on gagne une broche d'entrée sortie.

Le jeu de commandes standard

Instructions | Code |  |  |  |  |  |  |  |  |  | Description | Durée
 | RS | R/W | D7 | D6 | D5 | D4 | D3 | D2 | D1 | D0
Clear Display | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | Efface l'ensemble de la mémoire de donnée sans toucher au générateur de caractères. Ramène le curseur en position « home », à l'adresse 00. | 1,64 ms
Return home | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | X | Ramène le curseur en position « home », à l'adresse 00. Si l'affichage était décalé, il est remis à sa position d'origine : l'adresse 00 se trouve à nouveau en haut à gauche. | 1,64 ms
Entry mode set | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | I/D | S | Définit le sens de déplacement du curseur après l'apparition d'un caractère (vers la gauche si I/D=1, vers la droite si I/D=0) et si l'affichage accompagne le curseur dans son déplacement ou non (S). | 40 µs
Display on/off control | 0 | 0 | 0 | 0 | 0 | 0 | 1 | D | C | B | Met l'affichage en ou hors fonction l'affichage (D), le curseur (C), le clignotement du curseur (B). | 40 µs
Cursor and display shift | 0 | 0 | 0 | 0 | 0 | 1 | S/C | R/L | X | X | Deplace le curseur (S/C=1) ou l'affichage (S/C=0) d'une position vers la gauche (R/L=1) ou la droite (R/L=0) sans changer la DD RAM. | 40 µs
Function set | 0 | 0 | 0 | 0 | 1 | DL | N | F | X | X | Définit la taille de l'interface (DL=0 pour mode 4 bits, DL=1 pour mode 8 bits), le nombre de lignes (NL=0 pour 1 ligne, N=1 pour 2 ou 4 lignes), et la taille des fontes (F=0 pour des caractères 5x7, F=1 pour des caractères 5x10). | 40 µs
Set CG RAM address | 0 | 0 | 0 | 1 | A5 | A4 | A3 | A2 | A1 | A0 | Définit l'adresse de la CG RAM. Les données de la CG RAM sont envoyées après cette commande. | 40 µs
Set DD RAM address | 0 | 0 | 1 | A6 | A5 | A4 | A3 | A2 | A1 | A0 | Définit l'adresse de la DD RAM. Les données de la DD RAM sont envoyées après cette commande. | 40 µs
Read busy flag & address | 0 | 1 | BF | A6 | A5 | A4 | A3 | A2 | A1 | A0 | Lit le flag busy (BF), et l'adresse de la position du curseur. BF vaut 0 si l'afficheur accepte une instruction, 1 s'il est occupé | 1 µs
Write data to CG or DD RAM | 1 | 0 | D7 | D6 | D5 | D4 | D3 | D2 | D1 | D0 | Ecrit des données dans la DD RAM ou la CG RAM. | 40 µs
Read data | 1 | 1 | D7 | D6 | D5 | D4 | D3 | D2 | D1 | D0 | Lit les données de la DD RAM ou de la CG RAM. | 40 µs

Après avoir défini le sens de déplacement, les caractères apparaissent au dessus du curseur (qu'il soit visualisé ou non). On peut déplacer le curseur en utilisant la commande « Set DD RAM address ».

Un défilement des caractères est aussi possible, il suffit pour cela d'envoyer la commande 07H (I/D=1, S=1), sans oublier de positionner RS à 0. Mais il faut faire attention car un décalage de l'affichage décale également les adresses de l'afficheur de sorte que l'extrême gauche de la ligne supérieure ne soit plus adressable à l'adresse 00. La commande « Return home » permet de repositionner les adresses de l'affichage.

Le jeu de caractères standard

Les afficheurs utilisent tous le même type de contrôleur qui permet d'afficher l'ensemble des caractères ASCII, ainsi que quelques symboles et un jeu de caractères japonais stylisé. Les caractères accentués français ne font pas parti du jeu de ces contrôleurs. Fort heureusement, on peut tout de même afficher tous les caractères désirés grâce à des caractères définissables par l'utilisateur. Ceux-ci sont au nombre de huit et correspondent aux caractères de 0 à 7.

L'afficheur est en mesure d'afficher 200 caractères :

  • de 00H à 07H : 8 caractères définissables par l'utilisateur
  • de 20H à 7FH : 96 caractères ASCII excepté le caractère \ qui est remplacé par le signe ¥
  • de A0H à DFH : 64 caractères japonais (alphabet kana)
  • de E0H à FFH : 32 caractères spéciaux (accent, lettres grecques, ...)
Jeu de caractères standard

Initialisation

En mode 8 bits

À la mise sous tension de l'afficheur, la ligne supérieur devrait être totalement sombre, celle du bas complètement claire. Si tel n'était pas le cas, il faudra régler le contraste de l'afficheur en jouant sur la tension de la broche Vo.

Avant de pour pouvoir utiliser l'afficheur, il faut tout d'abord l'initialiser. Pour cela, la première commande à envoyer, est le commande permettant de définir le mode de dialogue avec l'afficheur (DL), et le nombre de ligne sélectionnées (N), et l'envoyer plusieurs fois de façon à ce que celle ci soit comprise, que le mode de départ soit quatre ou huit bits. On peut ensuite paramètrer l'afficheur, puis l'effacer.

Voici donc les différentes commandes (RS=0) à envoyer à l'afficheur LCD. Entre chaque valeur, il faut envoyer une impulsion d'au moins 450 ns sur la ligne E :

  • 33h, 33h, 33h : on force le LCD en mode 8 bits (3xh)
  • 38h : mode 8 bits, 2 lignes, caractères 5x7
  • 0Ch : affichage en fonction, pas de curseur
  • 06h : le curseur se déplace vers la gauche
  • 01h : on efface l'afficheur

En mode 4 bits

Pour l'initialisation d'un afficheur en mode quatre bits, on commence par forcer celui-ci dans le mode huit bits, puis quand on est sûr que celui-ci est valide, on bascule en mode quatre bits. Comme on ne sait pas au début de l'initialisation si l'afficheur est positionné en quatre ou huit bits, il est nécessaire d'envoyer la commande de passage en mode huit bits plusieurs fois de façon à ce que celle-ci soit comprise, que le mode de départ soit quatre ou huit bits. Les données sont écrites ou lues en envoyant séquentiellement les quatres bits de poids fort suivi des quatres bits de poids faible, séparés par une impulsion positive d'au moins 450 ns sur la ligne E.

En résumé, voici sur quatre bits, les commandes (RS=0) à envoyer à l'afficheur LCD. Entre chaque valeur, il faut envoyer une impulsion positive sur la ligne E.

  • 0h, 1h, 0h, 0h, 1h : on commence par effacer l'afficheur (01h)
  • 3h, 3h, 3h : on force le LCD en mode 8 bits (3xh)
  • 2h : on passe en mode 4 bits (20h)
  • 2h, 8h : mode 4 bits, 2 lignes, caractères 5x7 (28h)
  • 0h, Ch : affichage en fonction, pas de curseur (0Ch)
  • 0h, 6h : le curseur se déplace vers la gauche (06h)
  • 0h, 1h : on efface l'afficheur
© 1998-2008 Aurélien Jarno


Vu dans ... https://www.aurel32.net/elec/codes_barres.php

Les codes barres

Introduction

Omniprésents, les codes barres sont des acteurs discrets de la vie courante. Destinés à automatiser l'acquisition d'une information généralement numérique, ils trouvent leurs applications dans des domaines aussi variés que la gestion des prêts d'une bibliothèque, les caisses enregistreuses à lecture optique, ou le contrôle de la production dans l'industrie...

Toutes les informations peuvent êtres codées sous forme de mots binaires, c'est à la base de l'électronique numérique. Afin de permettre une acquisition rapide et automatique des données, différents procédés ont étés créés. Les codes barres sont particulièment bien adaptés au codage d'un chaîne numérique ou alphanumérique n'excédant pas quelques dizaines de caractères.

Impression d'un code

Il est très facile d'imprimer un code barres, il suffit pour cela de disposer d'une imprimante. Les codes-barres sont donc particulièrement économiques et c'est certainement là l'une des principales raisons de leur généralisation.

Lecture d'un code

Il existe deux moyens courants de lire les codes barres. Le plus classique est la lecture optique qui consiste à envoyer sur le code barres un faisceau lumineux (souvent un laser de très faible puissance) puis, à analyser la lumière réfléchie. Les codes barres utilisés sur les carnets de chèques sont imprimés à l'aide d'une encre magnétisable, dans ce cas la lecture sera alors magnétique. Le principe est alors le même que celui d'un lecteur de bande magnétique : une tête de lecture traduit en signaux électriques la succession de barres magnétisées.

Des lecteurs optiques de type « douchette » sont aujourd'hui connectables sur tous les micro-ordinateurs.

Normalisation EAN

L'EAN ou European Article Number est une norme garantissant que le code barres d'un article sera reconnu dans tous les pays de l'Union Européenne. L'EAN assure aussi une compatibilité avec les codes U.P.C. utilisés en Amérique du Nord.

Le mot codé est constitué de 8 ou 13 caractères répartis entre trois zone. En lisant de la gauche vers la droite, on trouve :

  • le « drapeau » codant sur deux caractères l'origine du code
  • la « zone utile de codage » qui comprend 10 caractères dont les 4 premiers représentent le fabricant et les 6 derniers l'article (cas d'un code sur 13 chiffres). Dans le cas de cette zone, le codage dépend de la zone d'origine.
  • le dernier caractère est le « code de contrôle » déterminant la validité du code. Il est calculé à l'aide d'un algorithme normalisé.

Note : Devant le grand nombre de pays utilisant les codes barres EAN, il a été décidé que le code pays pouvait comporter 2 ou 3 caractères. Dans ce dernier cas, le code fabricant ne comporte que 3 caractères.

Code barres EAN 8 chiffres | Code barres EAN 13 chiffres
La norme EAN 8 chiffres | La norme EAN 13 chiffres
La norme EAN 8 chiffres | La norme EAN 13 chiffres

En France, il a été décidé par l'association GENCOD d'inclure à la zone utile de codage le deuxième caractère du « drapeau », le premier caractère de celui-ci n'étant pas codé. Pour rechercher le fabricant d'un code barres d'origine francaise, suivez ce lien.

Interprétation selon la norme EAN

Les différents caractères sont représentés par la concaténation de deux symboles de base de largeur égales à 0,5 mm. Il existe deux symboles de base :

  • la barre noire, qui représente le 1 binaire,
  • la barre blanche, qui représente le 0 binaire.

Le code doit être lisible de la gauche vers la droite et de la droite vers la gauche, celui-ci a donc été divisé en deux parties par un séparateur. On trouve 01010 entre les parties droite et gauche du code et 101 aux extrémités du code, on notera que les séparateurs ont des barres plus hautes que les barres qu'il encadrent. Chaque caractère est codé à l'aide de 7 barres, c'est donc un codage sur 7 bits.

Trois jeux différents sont utilisés selon la position du chiffre dans le code. Les jeux A et B sont utilisés uniquement à gauche du milieu du code barres, sans ordre particulier, tandis que le jeu C est utilisé uniquement à droite de ce même milieu.

Caractère codé | Jeu A | Jeu B | Jeu C
0 | 0001101 | 0100111 | 1110010
1 | 0011001 | 0110011 | 1100110
2 | 0010011 | 0011011 | 1101100
3 | 0111101 | 0100001 | 1000010
4 | 0100011 | 0011101 | 1011100
5 | 0110001 | 0111001 | 1001110
6 | 0101111 | 0000101 | 1010000
7 | 0111011 | 0010001 | 1000100
8 | 0110111 | 0001001 | 1001000
9 | 0001011 | 0010111 | 1110100

Les codes des jeux A et B commencent tous par 0 et finissent tous par 1. Inversement, les codes du jeu C commencent tous par 1 et finissent tous par 0. Le codage d'un caractère n'implique donc que 5 bits sur 7. Exemple de code barres

Calcul du caractère de contrôle

Voici un exemple de calcul du caractère de contrôle d'un code EAN 13. Pour un code EAN 8, la procédure est la même, il y a seulement moins de chiffres à prendre en compte.

Code EAN | 4 007630 00011X
Chiffres | 4 0 0 7 6 3 0 0 0 0 1 1
Multiplier par | 1 3 1 3 1 3 1 3 1 3 1 3
Résultat | 4 0 0 21 6 9 0 0 0 0 1 3
Somme | 4 + 0 + 0 + 21 + 6 + 9 + 0 + 0 + 0 + 0 + 1 + 3 = 44
Division par 10 | 44 / 10 = 4 reste 4
Caractère de contrôle | 10 - reste = 6 (Si le reste de la division vaut 0, alors le caractère de contrôle vaut également 0).

Le code EAN final est donc dans ce cas 4 007630 000116.

Les codes pays

Le code pays dans la normalisation EAN est composé de 2 à 3 chiffres suivants les pays. Contrairement à une idée répandue, ce code ne correspond pas au lieu de fabrication du du produit, mais au pays dans lequel l'entreprise est membre du système EAN.

Code pays | Pays | Code ISO du pays
00 à 13 | USA & Canada | us & ca
20 à 29 | Usage privé uniquement |
30 à 37 | France | fr
380 | Bulgarie | bg
383 | Slovénie | si
385 | Croatie | hr
387 | Bosnie Herzegovine | ba
400 à 440 | Allemagne | de
45 & 49 | Japon | jp
460 à 469 | Fédération de Russie | ru
471 | Taiwan | tw
474 | Estonie | ee
475 | Lettonie | lv
476 | Azerbaijan | az
477 | Lithuanie | lt
478 | Ouzbekistan | uz
479 | Sri Lanka | lk
480 | Philippines | ph
481 | Belarus | by
482 | Ukraine | ua
484 | Moldavie | md
485 | Arménie | am
486 | Georgie | ge
487 | Kazakhstan | kz
489 | Hong-Kong | hk
50 | Royaume-Uni | uk
520 | Grèce | gr
528 | Liban | lb
529 | Chipre | cy
531 | Macédoine | mk
535 | Malte | mt
539 | Irlande | ie
54 | Belgique & Luxembourg | be & lu
560 | Portugal | pt
569 | Islande | is
57 | Danemark | dk
590 | Pologne | pl
594 | Roumanie | ro
599 | Hongrie | ie
609 | Ile Maurice | mu
611 | Maroc | ma
613 | Algérie | ie
619 | Kenya | ke
619 | Tunisie | tn
621 | Syrie | sy
622 | Égypte | eg
624 | Lybie | ly
625 | Jordanie | jo
626 | Iran | ir
627 | Koweit | kw
628 | Arabie Saoudite | sa
629 | Émirats Arabes Unis | ae
64 | Finland | fi
690 à 693 | Chine | cn
70 | Norvège | no
729 | Israël | il
73 | Suède | se
740 | Guatemala | gt
741 | Salvador | sv
742 | Honduras | hn
743 | Nicaragua | ni
744 | Costa Rica | cr
745 | Panama | pa
746 | République Dominicaine | do
750 | Mexique | mx
759 | Venezuela | ve
76 | Suisse | ch
770 | Colombie | co
773 | Uruguay | uy
775 | Pérou | pe
777 | Bolivie | bo
779 | Argentine | ar
780 | Chili | cl
784 | Paraguay | py
786 | Équateur | ec
789 | Brésil | br
80 à 83 | Italie | it
84 | Espagne | es
850 | Cuba | cu
858 | Slovaquie | sk
859 | République Tchèque | cz
860 | Yougoslavie | yu
867 | Corée du Nord | kp
869 | Turquie | tr
87 | Pays-Bas | nl
880 | Corée du Sud | kr
885 | Thailande | th
888 | Singapour | sg
890 | Inde | in
893 | Vietnam | vn
899 | Indonésie | id
90 et 91 | Autriche | at
93 | Australie | au
94 | Nouvelle-Zélande | nz
955 | Malaysie | my
958 | Macao | mo
977 | Périodiques (ISSN) |
978 & 979 | Livres (ISBN) |
980 | Reçus de remboursement |
981 et 982 | Coupons |
99 | Coupons |

Note : Les codes non actuellement attribués sont réservés pour une utilisation future.

Normalisation CMC7

Les banques de l'Union Européenne ont adopté le codage CMC7 qui permet la représentation des caractères alphanumériques à l'aide de 7 bâtonnets imprimés avec une encre magnétisable (voir en bas d'un chèque). Les 7 bâtonnets délimitent 6 intervalles qui peuvent être larges ou étroits, on obtient ainsi 26=64 combinaisons distinctes. La norme CMC7 permet aussi une lecture à "l'oeil nu" puisque les caractères sont dessinés à l'aide des bâtonnets.

Pour des raisons de fiabilité et de sécurité, les règles suivantes ont été respectées :

  • les caractères numériques ne sont codés qu'à partir de combinaisons comprenant deux intervalles larges et quatre intervalles étroits,
  • les caractères alphabétiques sont codés avec un à trois intervalles larges parmi les six intervalles.

Pour vous aider à décoder vos chèques, sachez qu'un intervalle large représente un 1 binaire alors qu'un intervalle étroit représente un 0 binaire.

© 1998-2008 Aurélien Jarno